View Issue Details

IDProjectCategoryView StatusLast Update
0023233mantisbtcustom fieldspublic2017-10-08 23:52
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.6.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0023233: Issues returned by filter has linked custom fields that are not available as columns
Description

Currently, when current project is ALL_PROJECTS, the list of available columns includes all custom fields (linked to any project).
However, when current project is any specific project, the columns list is populated only with custom fields linked to that individual project.

  • The behaviour is not consistent to that of ALL_PROJECTS
  • A filter can show issues from subprojects, that may have custom fields linked, but the user can't add those fields as columns if those fields are not linked to current project

Columns selection is currently linked to projects. Ideally they should go i hand with the filter scope.
As a reasonable solution, we can include custom fields from subprojects of current project, to make it work similar to the ALL_PROJECT case, and allow the user to add those columns for fields that are effectively searchable by the usual filters.
Note that the default filter (simple view_type) includes issues from subprojects.

TagsNo tags attached.

Relationships

child of 0023443 closedcproensa Fixes related to custom fields on filters, columns and visibility 

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master fe444f15

2017-08-16 20:10:57

cproensa


Committer: dregad Details Diff
Custom field columns include subprojects fields

Evaluate subprojects of current project to include readable custom
fields in the available columns list.
This allows adding a column for a custom field that is linked to a
subproject, which is the default behaviour when selecting ALL_PROJECTS.
Since columns are related to a project, but the filter by default shows
issues from subproject, extending the behaviour for any
project/subproject is consistent with the expectation that columns for
those custom fields can be used for view-all-bug page

Fixes: 0023233
mod - core/columns_api.php Diff File

Issue History

Date Modified Username Field Change
2017-08-16 20:51 cproensa New Issue
2017-08-16 20:57 cproensa Assigned To => cproensa
2017-08-16 20:57 cproensa Status new => assigned
2017-10-07 12:45 dregad Changeset attached => MantisBT master fe444f15
2017-10-07 12:45 cproensa Status assigned => resolved
2017-10-07 12:45 cproensa Resolution open => fixed
2017-10-07 12:45 cproensa Fixed in Version => 2.7.0
2017-10-07 13:33 atrol Target Version => 2.7.0
2017-10-08 11:50 cproensa Relationship added child of 0023443
2017-10-08 23:52 vboctor Status resolved => closed