View Issue Details

IDProjectCategoryView StatusLast Update
0023251mantisbttimelinepublic2017-10-09 03:05
ReportercproensaAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.6.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0023251: Timeline in view user page resets the user id after dates navigation
Description

Timeline in view_user_page.php resets the queried user after navigating the dates.

This casues that viewing user page, eg: view_user_page.php?id=2184
After navigation, the 'id' parameter is lost and it points to, eg: view_user_page.php?days=35 loading the page for current user instead
The correct link is view_user_page.php?id=2184&days=35

TagsNo tags attached.

Relationships

has duplicate 0023415 closedatrol view_user_page: an unintended user change when press "Prev" button. 

Activities

Related Changesets

MantisBT: master fc771e16

2017-08-21 13:28:58

cproensa


Committer: dregad Details Diff
Timeline preserve parent script parameters

Correctly preserve parent script parameters for navigation.

Fixes: 0023251
mod - core/timeline_inc.php Diff File

Issue History

Date Modified Username Field Change
2017-08-21 13:28 cproensa New Issue
2017-08-21 13:34 cproensa Description Updated View Revisions
2017-08-21 13:35 cproensa Assigned To => cproensa
2017-08-21 13:35 cproensa Status new => assigned
2017-08-21 13:35 cproensa Note Added: 0057523
2017-09-29 05:36 atrol Relationship added has duplicate 0023415
2017-10-07 12:11 dregad Changeset attached => MantisBT master fc771e16
2017-10-07 12:11 cproensa Status assigned => resolved
2017-10-07 12:11 cproensa Resolution open => fixed
2017-10-07 12:11 cproensa Fixed in Version => 2.7.0
2017-10-07 12:13 atrol Target Version => 2.7.0
2017-10-08 23:52 vboctor Status resolved => closed